neprihlásený Utorok, 20. novembra 2018, dnes má meniny Félix   DonaskaKvetov.sk - donáška kvetov v SR a zahraničí Pošli kvety
Štát ďalej zlyháva, po nových mali problémy aj existujúce eID

Značky: eIDSlovenskoe-government

DSL.sk, 11.7.2018


Zlyhávanie štátu v oblasti elektronizácie styku s občanmi cez elektronické občianske eID bohužial pokračuje a po problémoch občanov s eID s novými vydanými certifikátmi zaznamenávajú respektíve zaznamenávali problémy aj užívatelia s doterajšími eID so skôr vydanými certifikátmi.

Ako sme detailne popisovali v minulotýždňovom článku, štát nepochopiteľne zlyhal pri prechode na vydávanie certifikátov novým spôsobom a začal ich vydávať 2. júla hoci nesprístupnil kompatibilnú verziu potrebného softvéru eID klient.

Pre Windows nebol takýto softvér k dispozícii celý deň 2. júla a eID sa vôbec elektronicky nedali použiť a časť občanov a firiem tak nemohla v posledný deň lehoty odložených daňových priznaní tieto podať.

Pre užívateľov ďalších používaných a podporovaných OS na PC Linux a macOS problém trvá viac ako týždeň doteraz, keď stále nie je k dispozícii kompatibilná verzia softvéru eID klient.

Nový problém

Ako sa ale dnes ukázalo, problém majú aj užívatelia skôr vydaných eID so skôr vygenerovanými certifikátmi. Na DSL.sk sa dnes obrátil čitateľ, ktorému prestalo fungovať prihlasovanie na Slovensko.sk pomocou takéhoto eID s doterajšou verziou eID klient 1.9.4.

Následne v reakcii a po výzve eID klienta na upgrade prešiel na novú verziu eID klient 2.0.1. Pri tej sa ale ukázalo aj podľa informácií infolinky ústredného portálu, že táto verzia zase nie je kompatibilná s takýmito existujúcimi eID kartami so skôr vydanými certifikátmi.

Napriek tomu boli užívatelia verzie 1.9.4 vyzývaní, aby na túto verziu prešli. Aj výzvou softvérom eID klient aj napríklad informáciami o dostupnosti novej verzie na stránkach Slovensko.sk.

Riešením pre čitateľa tak bol návrat na verziu eID klient 1.9.4. Inštalačné súbory ale už nie sú k dispozícii na stiahnutie a infolinka mu poslala odkaz na stiahnutie na službu tretej strany pre zdieľanie súborov. Po jej opätovnom nainštalovaní bol eID a prihlasovanie na Slovensko.sk opäť funkčné.

Príčina problému

Zatiaľ nie je jasné čo bolo príčinou tohto problému, pri ktorom pôvodne verzia 1.9.4 prestala ísť s doterajším eID. Okno eID klienta otvárané pri prihlasovaní na Slovensko.sk podľa čitateľa vyzeralo ako by nebola v čítačke vložená karta, prihlasovanie realizoval na počítači a cez prehliadač kde sa od včera nerobili žiadne zmeny. Včera mu prihlasovanie ešte išlo.

Pred prihlasovaním ho eID klient 1.9.4 vyzval na upgrade, ten ale odmietol. Jednou možnou hypotézou je, že tento aj keď odmietnutý upgrade uskutočnil nejaké zmeny. Na druhej strane po tom, ako mu nešlo prihlásenie na Slovensko.sk a nezobrazila sa výzva na zadanie BOK-u, na danom počítači fungovala následne výzva a zadanie BOK-u iba po vložení karty realizovaná zrejme propagátorom certifikátov.

K pokusu o prihlasovanie prichádzalo ráno, kedy problémy so Slovensko.sk hlásili aj ďalší čitatelia. Minimálne problémy s úplne nedostupným prihlasovaním ale boli prítomné zrejme len krátko, čitateľovi takto prihlasovanie nefungovalo ale približne hodinu. Nefunkčnosť tak mohli tiež spôsobiť zmeny v procese prihlasovania na stránkach Slovensko.sk respektíve systémoch ministerstva vnútra.

Čo bolo príčinou problému verzie 1.9.4 s doterajšími eID tak nie je jasné, v každom prípade neskôr tomuto čitateľovi po opätovnom nainštalovaní tejto pôvodnej verzie aj iným čitateľom fungovalo na Windows aj iných OS prihlasovanie s verziou 1.9.4 a doterajšími eID. Zároveň ale ministerstvo vydalo dnes novú verziu eID klienta 2.0.2 a NASES oznámila na noc z piatka na sobotu mimoriadnu odstávku.

Problémy eID klient 2.0 s doterajšími eID

V každom prípade čítateľ sa po pôvodných problémoch s 1.9.4 rozhodol pre upgrade na ponúkanú verziu eID klienta 2.0.1, ktorá tiež nefungovala. V tomto prípade mu ale infolinka Slovensko.sk následne potvrdila, že to je známe správanie a s existujúcimi eID kartami je potrebné použiť staršiu verziu eID klient 1.9.4. Či žiadna existujúca eID karta nejde s novou verziou 2.0.1 nie je jasné, čitateľovi bola informácia ale podávaná takto.

Neskôr infolinka hovorila, že takýto problém môže nastať. V každom prípade má ísť o problém trvajúci už od začiatku minulého týždňa, aktuálne vyplával viac na povrch zrejme po tom ako eID klient začal vyzývať na upgrade na verzie 2.0.x.

Neakceptovateľná komunikácia

Ešte horšie ako tieto problémy, ktoré štát spôsobuje svojim občanom nezvládaním tejto oblasti, je spôsob komunikácie štátu o týchto problémoch.

Organizácia NASES zodpovedná na strane štátu za Slovensko.sk na žiadne otázky DSL.sk k dnes zistenému problému neodpovedala s tým, že na ne odpovie ministerstvo vnútra zodpovedné za eID a prihlasovanie pomocou eID. Zo zatiaľ dostupných informácií nie je vylúčené, že za všetky popísané problémy sú zodpovedné riešenia na strane štátu patriace pod ministerstvo, v takom prípade by sa samozrejme posunutie NASES dalo akceptovať.

V každom prípade ministerstvo vnútra ale na otázky položené doobeda až do večera vôbec nezareagovalo.

Navyše ministerstvo už viac ako týždeň neodpovedá na väčšinu otázok k problému s eID s novými certifikátmi vydávanými od 2. júla.

Okrem občanov, ktorých sa takéto problémy dotknú medzi prvými a na vlastnej koži a míňaním vlastného času často sami hľadajú fungujúce riešenia, sa tak zbytočne môžu takéto problémy dotknúť aj občanov, ktorí by sa mohli pri promptnom informovaní následne vyhnúť takýmto problémom.

V každom prípade je opäť až nepochopiteľné prečo ak eID klient 2.0.x nebol plne funkčný so skoršími eID so skoršími certifikátmi ako hovoria informácie z infolinky Slovensko.sk, prečo toto buď nebolo zistené ešte pred vydaním verzií 2.0.x respektíve ak bolo prečo neboli na to užívatelia upozornení alebo dokonca prečo potom eID klient 1.9.4 vyzýval na upgrade na verziu 2.0.x aj užívateľov, s ktorými eID nebol plne funkčný.


      Zdieľaj na Twitteri



Najnovšie články:

Jediná loď na Mars za štyri roky pristane presne o týždeň
Najnovšia ochrana proti Spectre výrazne znížila výkon Linuxu na Inteloch
Ubuntu 18.04 bude podporované až 10 rokov
Futuristický senzor na oku od Google nebude, nefungoval
Uvedený ďalší QLC SSD, prvý od nezávislého výrobcu


inzercia



Diskusia:
                               
 

Kradnu na kazdej urovni. A toto je vysledok.
Odpovedať Známka: 10.0 Hodnotiť:
 

vôbec nie, čo ma rozum ušlo do zahraničia, a na to netreba ani dokončené tunelo-dialnice.

To čo ostalo, detičky papalášov na poriadnu robotu nemajú bunky.

Opraviť geto internaty nestačí.
Odpovedať Známka: 6.2 Hodnotiť:
 

A ešte nám tu zostali v Bratislave premúdrelí východnare.
Odpovedať Známka: -3.7 Hodnotiť:
 

Správne, čo je v našej sociaľistickej spoločnosti hnilé, nech odpadne. Nech si idú, tí všetci mľadí, ľeniví sopliaci, krikľúni, darmožráči, janičiari, reakcionárske živle ta het preč, ktorým sa nechce makať za mzdy 1300,50€ mesačne. Však nikto ich tu nasilu nedrží. Boľševici a eštébáci majú svojich vyvolených, prekotom nakotených, protekčných parchantov dostatok, aby úspešne zastali chod tejto krajiny v každom riadiacom poste "súdruha riaditeľa".
Odpovedať Známka: -6.4 Hodnotiť:
 

Veď nech idú študenti do sveta ale nech si za štúdium zaplatia trhovú cenu.
Odpovedať Známka: 5.0 Hodnotiť:
 

ja som zvedavy ako dlho sa toto obrovske zlyhanie bude este natahovat, ake to bude mat nasledky a kto to napravi, a ci vobec nejake nasledky budu a ci sa to naozaj vobec napravi. Ale podla mojho nazoru toto bude dlhodoby stav, ktory sa bude napravovat 15 rokov a potom sa to mozno fixne totalnym spagetovym kodom a bude to jak wordpress.
Odpovedať Známka: 7.8 Hodnotiť:
 

samozrejme ten spagetovy kod sa bude robit pocas tych 15 rokov, spagetami budu fixovat diery, ale problem bude ze niektore spagety budu este aj hnile a prinesu radu dalsich problemov.
Odpovedať Známka: 10.0 Hodnotiť:
 

Ved ked rada starsich nie je uznasaniaschopna, demokraticky objektivne je na rade priekazne rada dalsich.
Odpovedať Známka: 1.1 Hodnotiť:
 

No pokial tento narod bude volit tie iste politicke strany a strany, ktore propaguju v skutocnych mediach tak sa to nezmeni nikdy.

Vy sami nechcete radikalnejsie zmeny fungovania parlamentu a institucii.

Ste posrati lebo nahodou by neboli banany na pultoch.

A to nemyslim LSNS lebo su rovnaki.
Odpovedať Známka: 10.0 Hodnotiť:
 

Rovnakí nie sú. Sú oveľa horší. Skladník, robotník, ochrankár, sem tam pidiživnostník a podobne. Hlavne je dôležitá zbierka plagátov a strelných zbraní a zadok otočený na východ.
Odpovedať Známka: -6.0 Hodnotiť:
 

No a co? Praveze to su obycajny ludia a tych je tu najviac.

Preco by v politike mali byt nejaky nadludia.

Hlavne musia byt normalny zdravo uvazujuci. Nebaziacich po moci a prniazoch.

Zastupenie v rade musi byt siroke a hlavne sa musi komunikovat. Velmi vela veci sa musi zmenit. Je to nadlho.


Hlavne nevol nasledujuce volby inak sa zucastnujes na tomto stave. Ci prepadnu alebo nie nasrat. Ide o svedomie.
Odpovedať Známka: 6.0 Hodnotiť:
 

Ideologicky suhlasim, akurat mozno vacsina obycajnych ludi, ktorych je tu najviac, nepouziva zdravy rozum a bazi po moci a peniazoch rovnako ako ti, co su tam teraz.
Odpovedať Hodnotiť:
 

Presne tak! Na riadenie štátu musíš byť vyštudovaný v tom jedinom správnom obore... herectve. Lebo, keď vyštuduješ herectvo, tak sa z teba automaticky stane odborník na všetko! Viď mnoho príkladov z parlamentu a z ulíc...
Odpovedať Hodnotiť:
 

Bavíš sa?Ťa to ešte baví?Ok
Odpovedať Hodnotiť:
 

Na tom, ze ked obcan moze mat maximalne jedno eID, funkcnost aktualneho a skorsieho certifikatu zaroven oficialne nie je mozne garantovat otestovanim ziadnou osobou predsa nic nepochopitelne priekazne nie je.
Odpovedať Známka: -1.1 Hodnotiť:
 

Že ďakujeme ti štát!
Odpovedať Známka: 10.0 Hodnotiť:
 

Ako som uz na tomto webe pisal: ak chce niekto podnikat v tejto bananovej republike, musi suhlasit s licencnymi podmienkami jednej konkretnej zahranicnej korporacie. A pripadne sa aj podrobit jurisdikcii ineho kontinentu (precitajte si ich niekedy poriadne) - pche, a to si Slovakistan hovori ze "zvrchovany stat" :-DDDD

Uz aj clanok na dsl.sk poukazoval na zoznamy zakazanych webov podla metodiky UK prava.
Odpovedať Známka: 10.0 Hodnotiť:
 

Tiež som si dal novú verziu a tvári sa, že nie je pripojená čítačka.
Odpovedať Hodnotiť:
 

Najväčšia sranda je, keď idem vypĺňať elektronické formuláre na finančnej správe a vyskočí na mňa strašne špecifická chyba "Sender not trusted"
Odpovedať Známka: 10.0 Hodnotiť:
 

ja mam stary obciansky na ktorom som si koncom minuleho roka vymenil certifikaty a vsetko mi funguje aj s verziou 2.0
Odpovedať Známka: 10.0 Hodnotiť:
 

--------------- --------------- ---------------
boze na nebi daj aby pre normalnych ludi a fyzicke osoby (ktore nemaju absolutne nic s podnikanim ani nicim inym) nespravil tento stat nieco elektronicky (a uz nijako inak) povinne pred rokom 2030 - dovtedy sa to hadam trocha vypiluje k lepsiemu
--------------- --------------- ---------------
Odpovedať Hodnotiť:
 

Dovtedy sa hadam vymeni vladnuca strana a cely tento system hodi do kosa.
Odpovedať Hodnotiť:
 

11.7.2018 prihlasovanie do starý certifikát ok na ID a verzia eid 2.0 - dalo sa prihlásiť Windows 10 pro systém.
Odpovedať Známka: 5.0 Hodnotiť:
 

Redaktor dsl.sk sa cuduje na nepochopitelnosti, ze to neslo so starsimi eID, ale ak sucasne zmeny robili a testovali ludia, co nemali tusenia, ze su tam zmeny oproti povodnym eID, napriklad v podpisovani, alebo komunikacii, tak kludne ich mohlo napadnut to neotestovat na starich vydavanych eID. Asi sa to tam strieda ako na beziacom pase, alebo sa ponahlali nieco rychlo vydat a jediny problematiky znaly pritom nebol.
Odpovedať Známka: 10.0 Hodnotiť:
 

Mne na Windows 10, verzia aplikácie 2.0.2, stará eID karta všetko funguje.
Odpovedať Známka: 10.0 Hodnotiť:
 

Je nejaky termin, kedy by mali vydat eID klienta 2.x aj pre MacOS a linux?

Mam certifikaty vydane po 2018-07-02 a len to vypisuje, ze je "neznama karta"...
Odpovedať Hodnotiť:
 

Vytvoriť niečo čo nefunguje na mobilných OS je v dnešnej dobe nonsens. Ak môžu na mobilných OS fungovať bankové aplikácie, rôzne iné aplikácie ktoré používajú biometrické údaje tak na tom ohľadne bezpečnosti môže fungovať aj tento nepodarok.
Odpovedať Hodnotiť:
 

Nemate nahodou niekto instalacku bokom? na mac, starej verzie eID, mam rovnaky problem ako v clanku ... hruza des
Odpovedať Hodnotiť:

Pridať komentár